Skip to content

OpenScope Tech Notes

Note Options menu not available in OpenScope

TN0978

Product: OpenScope, OpenEx, Synapse
Version: < OpenEx 2.24 / Synapse 84
Date Added: 2016-08-13

Issue

After opening an existing XSP file, the Note Options shortcut menu can't be displayed. When creating a new XSP file, the Note options are available, but changes can't be saved.

Solution

Upgrade to the latest version of OpenEx or Synapse.

OpenScope timeline locks-up when animating long recordings

TN0975

Product: OpenScope
Version: < 2.24
Date Added: 2016-08-13

Issue

When animating a recording with a duration of a day or more, the OpenScope timeline becomes bogged down with screen repaints, sometimes making the interface unusable.

Solution

Upgrade to the latest version of OpenEx or Synapse.

Using OpenEx clients across a network with Windows 7

TN0954

Product: OpenEx, OpenDeveloper, OpenController, OpenScope
Version: All
Date Added: 2015-04-28

Issue

Security settings must be modified on both the server and client computers to allow simultaneous access to a Workbench server running an OpenEx project from more than one computer.

Solution

Before software components distributed across networked computers can communicate with each other, several DCOM security settings must be modified on the server computer. The steps below ensure a client computer can access data from a registered new or legacy format tank located on a server computer.

In this example, the computer connected to the TDT hardware is named TDTServer. The computer that will run OpenController or TDevAccX remotely has a user account client1 with password password1.

Server Computer

Create a user account on the server computer:

  1. From the Control Panel, double-click Administrative Tools and then double-click Computer Management. If necessary, expand System Tools in the left panel and then expand Local Users and Groups.
  2. Right-click Users and select New User from the shortcut menu.

    The account user name and password MUST match the client computer's user name and password.

  3. In the New User dialog box, type the user name (client1) and password (password1) in the corresponding fields.

    Clear the User must change password at next logon check box and then select the User cannot change password and Password never expires check boxes.

  4. Click Create and then click Close.

This account must be an Administrator. To grant administrator privileges you must add that user to the Administrators group.

Add the user to the Administrators group:

  1. In the Computer Management window, under System Tools and then Local Users and Groups, click **Groups **in the left panel.

  2. In the window on the right, right-click the Administrators group and select Add to Group on the shortcut menu.

    The Administrators Properties window will open.

  3. Click the Add button. The Select Users, Computers, Service Accounts, or Groups window will open.

  4. Enter the user name in the Enter the object names to select field and click the Check Names button.

    Note

    If the user is not found, you may need to browse for a different location, using the Locations button.

    If the computer is on a domain, this step will have to be performed for both the local account and the network account.

    To change between the local machine and the network, click Locations and select either the machine or the network and click OK to return to the previous window.

  5. In the Select Users, Computers, Service Accounts, or Groups window Verify the spelling, and click OK.

  6. Close the **Computer Management **window.

  7. The Control Panel and Administrative Tools windows should still be open (if not, reopen now). Double-click **Component Services**in the panel on the left.

  8. Expand Component Services, expand Computers, right-click My Computer, and click Properties.

  9. In the My Computer Properties window, click the COM Security tab.

  10. Under Access Permissions, click the Edit Default button.

  11. Under Access Permissions in the My Computer Properties window, click the Add button. The Select Users, Computers, or Groups window is displayed.

  12. In the Enter the object names to select field, type client1.

  13. Click the Check Names button.

    Note

    If the user is not found, you may need to browse for a different location, using the Locations button.

  14. Verify spelling, then click OK.

  15. In the Access Permissions window, ensure the names SYSTEM, INTERACTIVE, and client1 are all present and all have Local Access and Remote Access permission.

    If any group names are missing, click Add to enter the group name.

  16. Click OK.

  17. Under Access Permissions in the My Computer Properties window, click the Edit Limits button and then click the Add button.

  18. In the Enter the object names to select field, type client1. Click the Check Names button, verify spelling, then click OK.

  19. In the Access Permission window, ensure the group names ANONYMOUS (or ANONYMOUS LOGON), Everyone, and client1 are all present and all have Local Access and Remote Access permission. If any group names are missing, click Add to enter the group name as before.

  20. Click OK. and return to the My Computer Properties window, COM Security tab.

  21. Repeat steps 10-20 under the Launch and Activation Permissions options.

Turn off the windows firewall:

  1. From the Control Panel, open Windows Firewall, and select the Off radio button.

  2. Click OK.

  3. From the Control Panel, double-click Administrative Tools, and then Component Services. Expand Component Services, expand Computers, expand My Computer, and double-click DCOM Config (you can click No if you are asked to record a registry value at this point).

  4. Right-click XpMaker and select Properties.

  5. On the Identity tab, ensure that The Interactive User is the account selected to run this application.

  6. Repeat steps 3 and 4 for TTankEng in the DCOM Config.

  7. After you finished making the security setting changes, reboot the server computer.

Client Computer

Test the communication link by pinging the server computer from the client computer and verifying the connection in OpenController.

To ping the server computer from the client computer:

  1. From the Start menu type cmd in the search box.

    Press the Enter key.

  2. A DOS command prompt opens, type ping TDTServer

  3. Verify that the server computer was reached and responded to the ping.

Add a registry entry with the user name and password of the client computer:

  1. From the Start menu type regedit in the search box, and press the Enter key. If a prompt for confirmation is display, click Yes.

  2. In the Registry Editor window, expand HKEY_LOCAL_MACHINE, SOFTWARE, Wow6432Node, TDT, and then TTank.

    Note

    For Windows 7 32-bit systems, expand HKEY_LOCAL_MACHINE, SOFTWARE, TDT, and then TTank.

  3. Right-click the EnumServers folder and select New String Value.

  4. Type the server name (TDTServer) as the Value Name and press Enter.

  5. Right-click the Value name and click Modify. Add the server name, user name and password for Value Data in the following form:

    TDTServer client1 * password1

    Important

    This is case sensitive and must include the asterisk and spaces

    After the entry is added, the registry should look like the example below:

    While Workbench is running on the server computer, test communication from the client in OpenController.

  6. Launch OpenController.

  7. In the Edit menu, click Window Property. The Setup Default Properties dialog will open.

  8. In the Default Server Name box, click the "..." browse button to view available servers.

    The server name that was entered in the registry is now available.

  9. Click TDTServer to highlight it, then right-click TDTServer, and click Test Connection on the shortcut menu.

  10. If the connection was successful, the following message dialog will be displayed:

  11. Click OK.

  12. Double-click TDTServer to select it as the default server for Controller.

  13. Click OK.

    You should now have access to the Workbench server running the TDT equipment just like you would if you were running Controller locally on that machine.

  14. On the client computer, launch OpenController.

  15. Add a ValueWatch control.

  16. Double-click the ValueWatch control and click the "..." browse button for the Source Target. The Select Target dialog will launch and display available targets as shown below. If this dialog is empty, or if you get an Access Denied error, try turning off User Account Control (UAC) on both machines, reboot and test again.

  17. If you are simultaneously accessing tank data while Workbench is recording, test tank communication from the client in OpenScope.

    1. Launch OpenScope.

    2. In the File menu, click Data Source to open the Select Tank dialog.

    3. Click the Server button to open the Select Server dialog.

    4. Repeat steps 8-11 to test communication and select the remote server.

'Subscript out of range' error message appears when setting a TimeRef epoch

TN0866

Product: OpenExplorer, OpenScope, OpenBrowser
Version: All
Date Added: 2009-11-24

Issue

When setting a TimeRef epoch a "Subscript out of range" error message appears:

This error message is likely to occur when you have more than 10 epocs in a block under the following conditions:

OpenExplorer

  1. when setting a TimeRef epoch for a Histogram plot.

OpenScope

  1. when setting a TimeRef epoch for a Histogram plot.

  2. when setting a TimeRef epoch for a Raster plot.

  3. when setting "Source Name X-Axis" for Feature plot.

  4. when setting "Refresh Epoc Name" in Activity plot.

OpenBrowser

  1. when setting a TimeRef epoch.

Workaround

Manually type the epoc name into the field.

Using an OpenEx client across a network with Windows XP

TN0231

Product: OpenEx, OpenDeveloper, OpenScope, OpenController
Version: All
Date Added: 2006-12-20 (updated 2011-09-13)

Issue

Security settings must be modified on both the server and client computers to allow simultaneous access to a Workbench server running an OpenEx project from more than one computer.

Solution

Before software components distributed across networked computers can communicate with each other, several DCOM security settings must be modified on the server computer. The steps below ensure a client computer can access data from a registered new or legacy format tank located on a server computer.

In this example, the computer connected to the TDT hardware is named TDTServer. The computer that will run OpenControlleror TDevAccX remotely has a user account client1 with password password1.

Server Computer

Ensure that simple file sharing is disabled:

  1. Open a My Computer window.

  2. On the Tools menu, click Folder Options. Click the View tab.

  3. Under Advanced Settings, scroll down, and clear the Use simple file sharing (Recommended) check box.

  4. Click OK.

Create a user account on the server computer:

  1. From the Control Panel, double-click Administrative Tools, and then Computer Management.

  2. Expand System Tools, and then Local Users and Groups.

    Right-click Users and select New User from the shortcut menu.

  3. The account user name and password must match the client computer’s user name and password.

    Type the user name (client1) and password (password1) in the corresponding fields.

  4. Clear the User must change password at next logon check box, and select the User cannot change password and Password never expires check boxes.

  5. Click Create and then click Close.

This account can be a limited user account.

Give the user Local and Remote access:

  1. From the Control Panel, double-click Administrative Tools and then Component Services.

    Expand Component Services, expand Computers, right-click My Computer and click Properties.

  2. In the My Computer Properties window, click the COM Security tab.

  3. Under Access Permissions, click the Edit Default button and then click the Add button.

    The Select Users, Computers, or Groups window is displayed. In the Enter the object names to select field, type client1. Click the Check Names button, verify spelling, then click OK.

  4. In the Access Permissions window, ensure the names SYSTEM, INTERACTIVE, and client1 are all present and all have Local Access and Remote Access permission.

    If any group names are missing, click Add to enter the group name as before.

    Click OK.

  5. Under Access Permissions in the My Computer Properties window, click the Edit Limits button and then click the Add button.

    1. In the Enter the object names to select field, type client1.

    2. Click the Check Names button, verify spelling, then click OK.

    3. In the Access Permission window, ensure the group names ANONYMOUS (or ANONYMOUS LOGON), Everyone, and client1 are all present and all have Local Access and Remote Access permission. If any group names are missing, click Add to enter the group name as before.

    Click OK.

  6. Under Launch and Activation Permissions in the My Computer Properties window, click the Edit Default button and then click the Add button.

    1. In the Enter the object names to select field, type client1.

    2. Click the Check Names button, verify spelling, then click OK.

    3. In the Launch Permission window, ensure the group names SYSTEM, INTERACTIVE, and client1 are all present and all have Local Launch, Remote Launch, Local Activation, and Remote Activation permission. If any group names are missing, click Add to enter the group name as before.

      Click OK.

  7. Under Launch and Activation Permissions in the My Computer Properties window, click the Edit Limits button and then click the Add button.

    1. In the Enter the object names to select field, type client1.

    2. Click the Check Names button, verify spelling, then click OK

    3. In the Launch Permission window, ensure the group names Administrators, Everyone, and client1 are all present and all have Local Launch, Remote Launch, Local Activation, and Remote Activation permission. If any group names are missing, click Add to enter the group name as before.

      Click OK.

Turn off the windows firewall:

  1. From the Control Panel, open Windows Firewall, and select the Off radio button.

  2. Click OK.

Select The Interactive User account to run the client application:

  1. From the Control Panel, double-click Administrative Tools, and then Component Services.

  2. Expand Component Services, expand Computers, expand My Computer, and double-click DCOM Config (you can click No if you are asked to record a registry value at this point).

  3. Right-click XpMaker and select Properties.

  4. On the Identity tab, ensure that The Interactive User is the account selected to run this application.

  5. If you would like to simultaneously access the tank data file that is recording in OpenEx through TTankX or OpenScope,repeat steps 11 and 12 for TTankEng in the DCOM Config.

  6. After you finished making the security setting changes, reboot the server computer.

Client Computer

Test the communication link by pinging the server computer from the client computer and verifying the connection in OpenController.

To ping the server computer from the client computer:

  1. From the Start menu click Run, type cmd, and click OK.

  2. In the DOS command prompt that opens, type:

    ping TDTServer

  3. Verify that the server computer was reached and responded to the ping.

Add a registry entry with the user name and password of the client computer:

  1. From the Start menu click Run, type regedit, and click OK.

  2. In the Registry Editor window, expand HKEY_LOCAL_MACHINE, SOFTWARE, TDT, and then TTank.

  3. Right-click the EnumServers folder and select New String Value.

  4. Type the server name (TDTServer) as the Value Name and type the user name and password for Value Data in the following form:

    * client1 * password1

    Important

    This is case sensitive and must include the asterisk and spaces

  5. After the entry is added, the registry should look like this example below:

  6. While Workbench is running on the server computer, test communication from the client in OpenController.

  7. Launch OpenController.

  8. In the Edit menu, click Window Property. The Setup Default Properties dialog will open.

  9. In the Default Server Name box, click the "..." browse button to view available servers.

  10. The server name that was entered in the registry is now available.

    Click TDTServer to highlight it, then right-click TDTServer, and click Test Connection on the shortcut menu.

  11. If the connection was successful, the following message dialog will be displayed:

  12. Click OK.

  13. Double-click TDTServer to select it as the default server for Controller.

  14. Click OK.

    You should now have access to the Workbench server running the TDT equipment just like you would if you were runningController locally on that machine.

  15. If you are simultaneously accessing tank data while Workbench is recording, test tank communication from the client in OpenScope.

    1. Launch OpenScope.

    2. In the File menu, click Data Source to open the Select Tank dialog.

    3. Click the Server button to open the Select Server dialog.

    4. Repeat steps 10 - 12 to test communication and select the remote server.

Some blocks of data do not appear in OpenScope and OpenBrowser

TN0089

Product: OpenBrowser, OpenScope
Version: All
Date Added: 2003-06-04

Issue

When using oxBuffers or oxSnippets with large block sizes (greater than 5000), some blocks of data do not appear in OpenScope and OpenBrowser.

Workaround

All blocks of data are still correctly stored in the tank, so the data can be exported and used with other software. If possible, keep block sizes smaller than 5000.

Solution

Use the provided storage macros.

Chart plot displays data incorrectly when viewed in multi-channel mode

TN0086

Product: OpenController, OpenScope
Version: All
Date Added: 2003-06-17

Issue

Chart plots are intended for displaying epoch events (data lists), wave snippets or buffered signals in OpenController and for epoch events and spike snippets in OpenScope. When plotting continuous data (Stream) in multi-channel mode, the display shows a waveform for channel one, but not the others or there is a lag in the other channels relative to the first channel.

Solution

To view stream data use a Scroll plot. Although the x-axis of a Scroll plots cannot be changed dynamically as with the Chart plot, the x-axis (duration) can be changed in the plot settings to enable you to view the waveform in greater detail.

To modify the duration of a Scroll plot, perform the following steps:

  1. Double-click the Scroll plot control to display the Setup Properties dialog box.

  2. Change the number of scroll sections under the Common Parameter Group settings.

  3. Click OK.